Jump to content

Logic as an 'audio host' via IAC


Syntho

Recommended Posts

I'm using some older versions of Logic (6 and below) but that shouldn't matter as everything I'm trying to do is done in the environment. The process should be the same no matter the version. Basically, i'm trying to compose midi in one program, but have Logic host all of my VST instruments, FX and everything.

 

I'm having trouble getting this working correctly because I can only have one track targeted and accepting midi at a time. I had to go to the 'OMS input mapping' area and select the IAC Bus as an input for midi to get into Logic. It's coming through, but now I can only send midi to the virtual instrument track that's targeted in the Arrange area. Somehow I've got to split it and get it sent to all tracks/VSTs.

 

How could I set up Logic's environment so that it could server as a sampler/VSTi/audio host and have it running in the background while composing in another application, using IAC? This is more complicated than I thought it would be.

Link to comment
Share on other sites

For up to 16 different instruments on 16 MIDI Channels, you can use the following instructions: https://www.logicprohelp.com/instruments-tracks-midi-channels/

 

If you need more than 16 instruments then you'll have to wire them manually in the environment, using multiple IAC busses and cabling them from the physical input object in the click and ports layer to the desired instrument channel strips. 

Link to comment
Share on other sites

When I cabled the IAC instrument objects to an audio instrument no notes were coming through. Then I cabled output of the IAC bus to an input monitor and no notes were coming through there either. The only way I got it to work was when I selected the IAC bus as an input instrument in the OMS mapping area.
Link to comment
Share on other sites

Ok, with the first method it looks like I still have to have the track targeted to get it to send midi to whichever instrument. I ticked the auto demix option, set up each instrument on a different midi channel, hit the record arm button, but midi only sends when the tracks are targeted. The channelization is working fine though. Take in mind i'm using some old versions of Logic, so I can't even select more than one track in the arrange area.

 

I can also try this in the environment, but as mentioned I can't get anything out of the IAC bus instruments that were create by default in the environment. Maybe they're there for being an input to the IAC bus only? Hmm...

Link to comment
Share on other sites

I did indeed R-enable the desired tracks. Only the one that's targeted has any midi going to it. I switch back and forth by clicking on the tracks in the arrange window and midi comes through, but only when those select ones are highlighted.

 

Also, there is an IAC bus port on the physical input object? I only see Sum and the modem and printer ports.

Link to comment
Share on other sites

Make sure you make the IAC bus active in Audio MIDI Setup. Then retrace your steps, use Monitors to check MIDI Channels, check your tracks' MIDI Channel, check the auto-demix setting... keep it easy at first, for example only R-enable two tracks on consecutive MIDI Channels (like 1 and 2), then make the set up more complex once you get it working. 
Link to comment
Share on other sites

I'm using Logic 5.5 on an old G4. I'm thinking this old version of Logic just can't handle sending to multiple instruments on input. I built an environment from scratch and the midi is coming from the 'sum' of the physical input object. No matter what - R-enabling multiple tracks and selecting the Demix option or not, it's only when I actually highlight/target the tracks in the arrange area do I hear anything. Their meters don't move unless it's actually highlighted. Funnily, midi is passing through the VST, because when I put a monitor on the output of it I see the data coming out, but it's only passing it on and not taking it itself.... unless I target the track in the arrange.

 

Logic 5 must have just been built to function that way. Even if I had hardware midi interfaces going back and forth with the same setup, I'm thinking I'd run into the same thing. I wonder how people handled this back then.

Link to comment
Share on other sites

I'm using Logic 5.5 on an old G4. I'm thinking this old version of Logic just can't handle sending to multiple instruments on input. I built an environment from scratch and the midi is coming from the 'sum' of the physical input object. No matter what - R-enabling multiple tracks and selecting the Demix option or not, it's only when I actually highlight/target the tracks in the arrange area do I hear anything. 

If you simply cable the SUM to the Sequencer Input then what you described is the expected behavior. You'd have to use channel splitters and cable the individual MIDI channels to different channel strips. 

 

You EITHER do that, OR you use the demix option, which does not require any custom environment. If the demix option is present in Logic's preferences then you can use it to route different MIDI channels to different R-enabled tracks (without having to select a track). 

 

Both techniques work, so pick one and keep it simple (only 2 MIDI channels with 2 instruments at first) and stay at it until you make it work. Ask if you have any questions. Provide details of what steps you've taken exactly and screenshots if possible. 

Link to comment
Share on other sites

1951099491_ScreenSharingPictureOctober52017at2_06.10AMCDT.thumb.png.1a8b610cca834418f8d9585a0f6afc9b.png

 

I tried both the channel splitter in the environment, and the Demix option. The tracks were both R-enabled. Both VST instruments are set to different midi channels, and the midi I have running into Logic also has two different lines of notes on two different channels. One is quarter notes, another 8th notes (ch.2), but it's not until I actually target the track that its respective sound/channel plays. I checked on another forum and someone told me that Logic 6 and prior just doesn't allow this to work right, and it wasn't until Logic 7 that eMagic/Apple allowed this to work right.

 

I'm thinking my problem is just old software.

Link to comment
Share on other sites

Well that's odd as since you don't have anything connected to your "Sequencer Input" object, selecting a track shouldn't affect anything. I don't remember Logic 5 being different from later versions in that regard. I wish I could experiment hands on with a copy of Logic 5 but I no longer have it. 
Link to comment
Share on other sites

Oh yeah, I forgot to mention that I tried it with and without the Sequencer Input object cabled, and I remember thinking that targeting a track and hearing its sound was weird too when the cable wasn't there. I think that right there shows us how that version of Logic was built.

 

Ah well. Thanks for the help anyway. I bought your book a few years back and it's great :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...