Jump to content

Varispeed takes longer to kick in on RME Fireface UFX+


autonom
 Share

Recommended Posts

Hi All,

 

I'm having an issue with Varispeed in Logic X (10.4.8) and the RME Fireface UFX+. When using this interface, Varispeed takes a few seconds to activate. When using the Focusrite Clarett 4Pre or the built in audio device in my Macbook Air (early 2014), Varispeed goes into effect immediately. Does anyone know what causes the delay with Logic on the RME? It is hooked up via USB3, (while the Clarett is on USB2) so I assumed it would respond even more quickly.

 

My scenario: I edit spoken word recordings and while scanning the raw material I keep switching back and forth between normal and double speed (via Varispeed dialed up to 100%). With playback running in Logic I hit a key command to activate Varispeed. As described above, the switch happens instanteneously on the Clarett and the internal audio device. On the RME the timeline keeps running after hitting the command with no output for about two seconds and then the timeline jumps back and I finally get to hear the recording in double time from the point where I hit the key command.

 

Any ideas where I could start looking to change parameters that affect this behaviour?

Link to comment
Share on other sites

That's odd.

I would believe that Logic doesn't interact with the RME soundcard to run and do audio processing, the soundcard would come at the end of same just to playback what it gets from Logic.

Wild guess: are your RME soundcard sampling rate set as same as Logic's own sampling rate setting?

Link to comment
Share on other sites

Hi, thanks for addressing my question.

I was wondering about clock issues as well, but I couldn't find any irregularities. The sampling rate settings are the same in the Logic project and the RME. Playback in regular speed starts instantaneously too. It is only the Varispeed playback that's affected. And I found out that it actually lags everytime I start playback in Varispeed, not only when switching it back on. On the RME that is.

Any further ideas?

Link to comment
Share on other sites

  • 4 months later...
No, I use only the laptop described above.

 

I came across this post as I was trying to find information on how the RME Fireface UFX+ works with Logic w.r.t latency and overall general performance. The UFX+ looks to be one of the few interface that offers both Thunderbolt 3 and USB3 - with the USB3 speeds being very fast because of RME's software. Or it is their kernel extension, RMEFirefaceUSB.kext, which you install on the Mac as part of the software you download which is supposed to give very low latency over USB3 on par with TB3. That is designed to work with a USB 3.0 chipset. It should work with newer 3.1, 3.2 chipsets, but the performance may not be the same. You could check that you have the latest version of that RME software installed.

 

I assume if you had Thunderbolt 3 out on the laptop you would be using it, so just curious how you are connecting to the laptop as USB3. I would verify you are not using an adaptor like the Apple USB C to USB adatpor - or anything that is not going to give you an actual USB 3.X connection. Usually USB 3 connectors are not white plastic but blue plastic on the inside (or some other color besides white on the inside of the connectors and sockets).

Link to comment
Share on other sites

Hi zplane,

 

Thanks for addressing this. Meanwhile I switched computers, but the issue is the same. I am using an Apple Thunderbolt 2 cable coming from the Ufx+. On the other end it is indeed plugged into an adapter: TB2 to TB3, also by Apple, and that goes into a TB3 port on a Mac Mini 2018. The behavior has not changed. There is still a considerable lag when hitting play while in VariSpeed mode. The drivers are all up to date. I will check if it’s different on USB3 with a dedicated cable, but I think I tested this combination already. Thanks again for the hint.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...