Jump to content

Cannot add images to track/project notes


Recommended Posts

Hi. Hope someone can help me.


Not really sure what I'm doing wrong, but for some reason I'm not able to add any images to my track/project notes. I've looked at several videos on how to do it and it seems it's just a simple drag and drop. But for some reason the image just doesn't show up. Yes I've pressed the edit button first.



Thanks and appreciate any help.

Link to comment
Share on other sites

yeah unfortunately not working for me. Appreciate your help though. For some reason I've seen in a tutorial video that if you right click it allows your to capture a screenshot and it will directly be added. however for some reason I don't have that option when I right click. I do have the option to take a photo from my iPhone however whenever I take the photo the image still won't show up.


It appears to be some sort of bug but for whatever reason limited to my machine. I am on an M1 pro though. Not sure if that has something to do with it. I reckon it shouldn't but reading your machines in your signature that seems to be the only difference.

Link to comment
Share on other sites

Right click within the project note text box (refer to screenshot I attached).


Tried following your instructions via the preview and copy all and pasting. No luck unfortunately.



As mentioned in the previous post I tried the take photo button via iphone but it doesn't work :(



Link to comment
Share on other sites

Hey David. I'm always a bit hesitant downloading unknown zip files. Sorry about that.

No worries, I understand ... in this case though it's just a Logic project file that I just created from a new empty project, with an image of a screenshot of a guitar pedal in Logic's pedalboard plug-in.


I might reach out to my local apple store to see if they're familiar with the issue.

If you find out anything please do let us know in this thread, it could help someone else who may have the same issue in the future! Thanks!



You're welcome. :)

Link to comment
Share on other sites

  • 4 weeks later...
Hey Ylan,


Thank you for posting that video. This is exactly what is happening to me. Tried to drag & drop png, jpg and it won't import. Cursor also becomes tiny.

I use this to record the settings on my outboard gear.


running 10.7.2 Must be a bug.


I did post a bug report at https://www.apple.com/feedback/logic-pro.html.


I hope they can fix it. Would encourage you to post as well, and anyone else with this problem.


Humbly, Ylan

Link to comment
Share on other sites

  • 3 weeks later...
Perhaps posting your system specs could help targeting which Mac is problematic?

I also noticed in your last video that you (seemingly) don't click on the notepad area before issuing a paste command...


Hello Atlas007!


Sorry, I didn't start the discussion in this thread, but got a nudge here. I run Logic Pro X 10.7.2 under MacOS Monterey 12.2.1 on my iMac (Retina 5K, 27-inch, 2017), 3,8 GHz Quad-Core Intel Core i5.


And yes I'm able to paste text into the notepad area, but not able to paste (or insert through Logic's own functions) images or photos.


Humbly, Ylan

Link to comment
Share on other sites

This functionality seems to have been disabled by a bug in LP 10.7 or Monterey.


Cheers Dox,


So I guess I will have to wait for Apple to do something about it. There's always something innit. I thought I was careful when upgrading, but I didn't check this one out.


Humbly, Ylan

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...