Jump to content

Can't reset sound library


FrankTeardrop
 Share

Recommended Posts

Hi folks,

 

The external drive where sound library was installed has die and i want to reinstall it in another ext. hd. I open logic it says "The sound library folder could not be found", i press reset. Says "Warning this will break, bla bla bla...". Reset. Logic ends loading and the nothing happens. Go to menu Logic -> Sound Library and the only option available is "Reinstall sound library", press it and again "Warning...", and again nothing happens. Dont know what to do after several searchs, forums discussions, etc. Pleasse help.

 

Thank you.

Link to comment
Share on other sites

Despite the "Warning…", did you try to re-download the library?

In the affirmative have you tried re-installing Logic?

LogicPro 10.7.4, MainStage 3.6,
MBPro 17", Core2Duo, 8G, OSX 10.12.6, MacPro, Xeon 6Cores, 64GB, OSX 10.16.1,
ULN8, MOTU MIDI TP-AV, C4, MCU Pro, KorgNano, Novation SLMkII, Several vintage gear
AAS, NI, Celemony, Spectrasonics, Korg, Arturia, etc..., PC, iPadPro 5th gen 12.9”(Duet D., V-Control & LogicRemote), AtariST(Notator SL),

Link to comment
Share on other sites

Sorry but how can i redownload the library if the only option is to reinstall and it does nothing when selectecd?. I havent reinstalled logic because i'm on catalina and the update available is for mac 11. Is there a way to reinstall the version i have?, i dont know... I was thinking and have been searching for some preference files where i can delete the path to the sound library so logic thinks it doesnt exist but i guess things doesnt work this way today because i havent found anything similar.. Any suggestion appreciated. Thanks.
Link to comment
Share on other sites

Nothing happens because i can see the apps trafic in the network monitor of the firewall and logic doesn't try to connect anywhere once opened. No progress bar because i load logic without project opening enable but have tried opening an empty project and loading virtual instrument track, browsing library... BUT just now i'm trying from garage band and seems something is happening. I mean, i have opened garage band (first time i do) and it warnings me with the same question but clicking "Reset" has made garage band downloading full bandwidth. I'll inspect logic after finished and comment. Thank you
Link to comment
Share on other sites

- So finished dling garage band essential coliection i opened logic and now it is dling more essential collection as it was the first time i use it.

- When it finish go to Logic menu -> Sound Library and still only available option is to Reinstall but now when i click it it says is going to replace old samples with actual ones and start to dl 2.18 GB.

- Ok, dled and installed. Only "reinstall" option available still. Restart logic and the same annoying message asking for the old HD with the sound library, and inside the menu no option to manage library just reinstall.

- Create a software inst. project with sampler one track and click "View Library". I can see what is dled and can dl what isn't.

Seems different things (library and samples) but are one in my head. Enough for now...

Link to comment
Share on other sites

I'm not sure what you're expecting instead of a "reinstall" option? Because you no longer have a sound library, you do have to reinstall one, and it will take time, so that every time you quit Logic and restart it it may prompt you that you still have content to download.

 

You can go choose Logic Pro > Sound Library > Sound Library Manager to determine what's installed and what's left to install. When you click for example "Download all available sounds", make sure you give Logic a good amount of time (depending on the speed of your connection) and you should be prompted to install what you've downloaded?

My new Logic Pro Book is out!

Link to comment
Share on other sites

hello i have exactly the same problem as frank

just posted viewtopic.php?f=1&t=160768&p=843973#p843973

 

david: the problem is that we cant go to Sound Library Manager because all the options are greyed out.

and i cant download garageband because i run 10.14.6

logic 10.5.1 build version 5229 - sound library 2324 (21 september 2021)

MacBook Pro (Retina, Mid 2012) 10.14.6 (18G9323) mojave

m-audio profire

Link to comment
Share on other sites

I read it is possible to install an older version of Logic Pro X downloaded from your user account on the App Store, providing that you are accessing same from a computer running macOS version corresponding to the desired Logic version.

IOW, if you are on BigSur or Monterey the only available version would be Logic v.10.7.1 (as of today 2021-11-13);

if your Mac is running OS El Capitan the available Logic version would be v.10.3;

for macOS Sierra, the available Logic version would be v.10.4;

etc...

The available version would be the most recent one running on that macOS.

LogicPro 10.7.4, MainStage 3.6,
MBPro 17", Core2Duo, 8G, OSX 10.12.6, MacPro, Xeon 6Cores, 64GB, OSX 10.16.1,
ULN8, MOTU MIDI TP-AV, C4, MCU Pro, KorgNano, Novation SLMkII, Several vintage gear
AAS, NI, Celemony, Spectrasonics, Korg, Arturia, etc..., PC, iPadPro 5th gen 12.9”(Duet D., V-Control & LogicRemote), AtariST(Notator SL),

Link to comment
Share on other sites

ok, but do you think that would solve the sound library problem?

by the way, i run mojave 10.14.6

Well not directly.

But that is part of the usual troubleshooting rundown when having problem with Logic

LogicPro 10.7.4, MainStage 3.6,
MBPro 17", Core2Duo, 8G, OSX 10.12.6, MacPro, Xeon 6Cores, 64GB, OSX 10.16.1,
ULN8, MOTU MIDI TP-AV, C4, MCU Pro, KorgNano, Novation SLMkII, Several vintage gear
AAS, NI, Celemony, Spectrasonics, Korg, Arturia, etc..., PC, iPadPro 5th gen 12.9”(Duet D., V-Control & LogicRemote), AtariST(Notator SL),

Link to comment
Share on other sites

 

You can go choose Logic Pro > Sound Library > Sound Library Manager to determine what's installed and what's left to install. When you click for example "Download all available sounds", make sure you give Logic a good amount of time (depending on the speed of your connection) and you should be prompted to install what you've downloaded?

 

we cant access that option because it's greyed out.

unfortunately that happens when you have to start logic with "ignore missing sound library"

Edited by marcvb

logic 10.5.1 build version 5229 - sound library 2324 (21 september 2021)

MacBook Pro (Retina, Mid 2012) 10.14.6 (18G9323) mojave

m-audio profire

Link to comment
Share on other sites

SOLVED!

the garage-band folder in HD/library/application support was missing

 

even though the logic sound library was present, logic did not recognise it without the garage-band folder (and subfolders with samples etc)

 

thanks a lot for helping!

logic 10.5.1 build version 5229 - sound library 2324 (21 september 2021)

MacBook Pro (Retina, Mid 2012) 10.14.6 (18G9323) mojave

m-audio profire

Link to comment
Share on other sites

  • 2 weeks later...

Hi all,

Solved?, i don't unsderstand what you have done. We where talking about logic sound library that maybe is shared with garage but what folder are you talking about?. I have a garage band folder inside /application support. The problem persists for me. I'm more in the side of #18 and i prefer to wait for the next update before install a previous one.

Link to comment
Share on other sites

  • 2 weeks later...

I'm experiencing the same issue as many in this thread and there are no external drives involved. The only option I can choose is "Reinstall Sound Library" and each time I do a blue progress bar redownloads what appears to be the essential ~1.5GB of sounds. I've done it several times and can't ever select the sound library manager. It didn't used to be this way, but it must be some recent combination of Logic Pro (10.7.1) and macOS (Monterey 12.0.1) updates that broke something. Unfortunately I don't have an older version of Logic Pro to downgrade to.

 

901315441_ScreenShot2021-12-05at3_54_24PM.png.cdf9564db7149ff95caca7185af2f39f.png

Link to comment
Share on other sites

  • 2 weeks later...
Does anyone know where Logic Pro looks in the MacHD/Library folder to figure out where the Sound Library files are supposed to be located? Every time I load Logic after a while it'll suggest the link is broken and if I say to keep it on the main system drive it'll ask for my admin password to install a Helper. Once completed I get no error messages, but I suspect nothing actually changes because it'll keep doing this over and over again. The only option I ever see under the Sound Library menu is Reinstall Sound Library.
Link to comment
Share on other sites

  • 3 weeks later...

yeah, same here, but did you try david's suggestion:

There must be a file in logic that points to this (non existing) location. but i cant find it. do you know where that file is?

There's a preference plist file inside the Logic Pro package. More info in the following thread:

 

How to stop Logic downloading Essential Sounds

 

i just didn't have the time to get into that yet.

my logic is now working fine without endless searches for nonexitingsamples, so I'm already glad. but i have to get into our problem one day

logic 10.5.1 build version 5229 - sound library 2324 (21 september 2021)

MacBook Pro (Retina, Mid 2012) 10.14.6 (18G9323) mojave

m-audio profire

Link to comment
Share on other sites

Every time I load Logic after a while it'll suggest the link is broken and if I say to keep it on the main system drive it'll ask for my admin password to install a Helper. Once completed I get no error messages, but I suspect nothing actually changes because it'll keep doing this over and over again. The only option I ever see under the Sound Library menu is Reinstall Sound Library.

 

did you try to install the garageband ? thats what helped me:

 

the garage-band folder in HD/library/application support was missing

 

even though the logic sound library was present, logic did not recognise it without the garage-band folder (and subfolders with samples etc)

logic 10.5.1 build version 5229 - sound library 2324 (21 september 2021)

MacBook Pro (Retina, Mid 2012) 10.14.6 (18G9323) mojave

m-audio profire

Link to comment
Share on other sites

Here's something that I encountered: "Reinstall Sound Library" was grayed-out and I couldn't figure out why.

 

I didn't remember that MacOS has a "fee-chur" in which you can hover the mouse over a grayed-out menu selection to find out why it was grayed out.

 

When I finally did this, it told me: "Current user is not an Administrator." Which, of course, is quite correct: this ol' computer-geek practices the "Principle of Least Privilege" in everything he does. I logged on to the (one and only ...) administrator account and proceeded.

 

I don't know why Logic's programmers decided to do things this way – usually, if you need elevated privileges you simply ask for them – and I definitely did not remember about hovering the mouse over a menu selection, which to me is a relatively new change to "how Macs work."

Mike Robinson - "I wanna quit being a computer consultant and become a composer and arranger at age fifty-nevermind."
Logic Pro X, MacBook Pro, 88-key MIDI controller.

Link to comment
Share on other sites

  • 5 months later...

I have the same problem folks,

I deleted the program and reinstalled logic completly anew. I also have emptied to my knowledge all old aliases to my external hardrive.

And yet it opens with the same greyed out soundlibrary options, except 're install'.

"Reinstall sound library" however does nothing :  After clicking on the reset button (to reinstall the sound library to default location) it does NOTHING.

How can we get a clean, new installation going?

I have ugraded to Monterey 12.4 and ever since my logic pro x is not working properly. (BTW it also does not have any 'undo' steps any longer, which is horrible) 

I have a new hardrive to which i want to install my soundbanks and was hoping for a new clean installation. Any help appreciated.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...